Problem with libicu66 during installation php-intl extension on Ubuntu 21.10

All we need is an easy explanation of the problem, so here it is.

sudo apt install php7.0-intl

Output:

The following packages have unmet dependencies:
 php7.0-intl : Depends: libicu66 (>= 66.1-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Previous versions never had a problem with this dependency

Any ideas?..

> uname -a

Linux ###### 5.13.0-21-generic #21-Ubuntu SMP Tue Oct 19 08:59:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

How to solve :

I know you bored from this bug, So we are here to help you! Take a deep breath and look at the explanation of your problem. We have many solutions to this problem, But we recommend you to use the first method because it is tested & true method that will 100% work for you.

Method 1

Panic canceled

just download binary

wget http://archive.ubuntu.com/ubuntu/pool/main/i/icu/libicu66_66.1-2ubuntu2_amd64.deb

And install it manually:

sudo dpkg -i libicu66_66.1-2ubuntu2_amd64.deb

After that you can install php-intl:

sudo apt-get install php7.0-intl

Now the installation is successful

Note: Use and implement method 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply