unable to install the latest nodejs

All we need is an easy explanation of the problem, so here it is.

I have tried many ways, via nvm etc.. nodejs stays stubbornly at v10 which is outdated, what could i do?

Err:12 http://ppa.launchpad.net/ubuntu-vn/ppa/ubuntu focal Release             
  404  Not Found [IP: 2001:67c:1560:8008::19 80]
Err:13 https://deb.nodesource.com/node_8.x focal Release
  404  Not Found [IP: 2001:ee0:3244::71ab:c39 443]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/ubuntu-vn/ppa/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.nodesource.com/node_8.x focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

How to solve :

I know you bored from this bug, So we are here to help you! Take a deep breath and look at the explanation of your problem. We have many solutions to this problem, But we recommend you to use the first method because it is tested & true method that will 100% work for you.

Method 1

i used nvm install --lts and it worked

Note: Use and implement method 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply