Windows 10 black screen after local login and previous remote desktop session

All we need is an easy explanation of the problem, so here it is.

On occasion when I am not physically at home, I will login remotely to my computer using Remote Desktop. When I return home I then have to login locally; however, immediately after login I am presented with a black screen. Has anyone else encountered this issue and know of a solution?

Additional Information

As far as I can tell the system appears to switch over to virtual devices for the remote desktop session, but when I then login locally it doesn’t switch back to the physical devices.

I don’t have any trouble with local logins normally. And I can login remotely repeatedly without issue. It’s only when I attempt to login locally after I have been logged in remotely that the issue occurs.

While viewing the black screen, Ctrl-Alt-Del does not appear to do anything. There is a mouse cursor visible that I can move around for a short time (5-10 seconds) before it freezes. Once it reaches this point, the only remedy I have found is to hard restart my computer physically using the power button.

The computer was upgraded from Windows 7 where I used to do the exact same thing and had no trouble at all. I could remote desktop into my computer assuming the existing session, then login locally and assume the same session, and repeat as I wished.

I have uninstalled and reinstalled drivers for my monitor (Samsung SyncMaster T240HD) and display adapter (EVGA NVIDIA GeForce GTX 670). I have logged into safe mode, enabled display all hidden devices, and uninstalled all other monitor or display adapter devices that I could find, which was only a single hidden monitor device for an old monitor I had.

I have checked the system, application, and security logs and found no warnings or errors either during the remote login or the subsequent local login.

How to solve :

I know you bored from this bug, So we are here to help you! Take a deep breath and look at the explanation of your problem. We have many solutions to this problem, But we recommend you to use the first method because it is tested & true method that will 100% work for you.

Method 1

Issue is related to the nVidia GeForce Experience ShadowPlay feature. When ShadowPlay is turned on (not recording just enabled), then the issue occurs. When ShadowPlay is turned off, then no issue. Whether the issue is ShadowPlay or Remote Desktop I can’t say, but the two of them interacting together on Windows 10 caused the black screen of death.

I’m not the only one to notice this problem. The only reason I even played with the setting was because someone else had a similar issue with a different version of the software: https://serverfault.com/questions/724459/black-screen-after-rdp-session

Method 2

Try checking the display settings and seeing if there is a phantom monitor present. Might need to change which monitor is the primary one. Also try uninstalling the monitor drivers under device manager.

Method 3

I was able to make this work with following suggestion.

https://superuser.com/a/1459488/1075541

In Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment, set the Policy Use `WDDM graphics display driver for Remote Desktop Connections’ from “Not Configured” to “Disabled.”

Note: Use and implement method 1 because this method fully tested our system.
Thank you 🙂

All methods was sourced from stackoverflow.com or stackexchange.com, is licensed under cc by-sa 2.5, cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply